Hansa client keeps crashing
Kenneth Macharia
2020-01-20
Hi,

I noticed a problem with all my Hansa client's for the 1 month whereby the Hansa wont run on the endpoint until they restart the computer/workstation.

I am on Standard ERP 8.1 2016-06-30
Intel/windows xp/windows 7
Build 81311201

Most of the operating system where Hansa client are installed runs on windows 10 and few windows 8

Kind regards
Macharia
This answer was correct
Created byKenneth Macharia12:41 30 Jan 2020
HI Michael,

Thanks. The main challenge is, none of any .exe files can run in the server folder located in my test platform. If you attempt Standard ERP Server.exe, runs a command windows and immediately closes out (creating a very small size of .hdb in the folder) and /or if you run Standard ERP.exe in the same server folder on test platform then it gives you side-to-side configuration error.

NB: However, Standard ERP.exe runs very well in the client folder under the same test platform workstation and runs import maintenance procedure and has all the data as expected. (Also noted is I dond have any SERP services running on the test platform workstation)

The challenge here is configuring the workout in the server folder as explained in the 1st paragraph above.

See the attached files layout screenshots both the client folder and the server folder to support the above. I have also attached both logs files for both the client and the server folder

Kind regards,

Macharia
Michael Wyeth
2020-01-22
Hi Kenneth

The version of Standard ERP you are running is not officially supported on Windows 10. While the client can be seen to run on windows 10, it is doing so in a compatibility mode. This explains why you see issues such having to restarting the computer running the client.

We recommend that you update your server and clients to a newer version of Standard ERP - Version 8.5 to be specific.

Best regards,

HansaWorld Support
Kenneth Macharia
2020-01-27
Created byMichael Wyeth07:12 22 Jan 2020
Hi Kenneth The version of Standard ERP you are running is not officially supported on Windows 10. While the client can be seen to run on windows 10, it is doing so in a compatibility mode. This explains why you see issues such having to restarting the
Hi Michael

Thanks alot for your swift response. I have since attempted to do an upgrade (test upgrade on version 8.5) but after following all the due process its running, giving an error of side-by-side configuration incorrect.

I have checked all my dot netframe versions installed and noticed my workstation has the most latest version and hence attempting to install v3.5 or 4.0 not possible.

Kindly see the attached Hansa error and advice

Kind regards
Macharia
Please log in to view the files
Michael Wyeth
2020-01-27
Hi Kenneth

Please can you confirm if you are running .NET framework 4.72 or higher? Anything lower will cause the side-by-side error message.

Best regards,

HansaWorld Support
Kenneth Macharia
2020-01-29
Created byMichael Wyeth13:56 27 Jan 2020
Hi Kenneth Please can you confirm if you are running .NET framework 4.72 or higher? Anything lower will cause the side-by-side error message. Best regards, HansaWorld Support
Hi Michael,

Thanks for the advice. I did an installation of .net 4.72 on my laptop (where I have setup a test platform) and after restore to the client folder, interestingly its running well with all the features and the data .

However, if I copy the same .hdb file from the client folder to the server folder on the same laptop test platform and attempt to run it, it gives me the side-side configuration error. Which step could I be missing especially on the server level?

regards
Macharia
Michael Wyeth
2020-01-30
Hi Kenneth

Please can you check if you have any other SERP servers / services running on your laptop. These might be conflicting with the server you are currently using.

Additionally, please can you remove the .hdb from your server, create a backup from the standalone system, and import that backup into the server, rather than copying the .hdb.

Best regards,

HansaWorld support
This answer was correct
Kenneth Macharia
2020-01-30
Created byMichael Wyeth07:41 30 Jan 2020
Hi Kenneth Please can you check if you have any other SERP servers / services running on your laptop. These might be conflicting with the server you are currently using. Additionally, please can you remove the .hdb from your server, create a backup
HI Michael,

Thanks. The main challenge is, none of any .exe files can run in the server folder located in my test platform. If you attempt Standard ERP Server.exe, runs a command windows and immediately closes out (creating a very small size of .hdb in the folder) and /or if you run Standard ERP.exe in the same server folder on test platform then it gives you side-to-side configuration error.

NB: However, Standard ERP.exe runs very well in the client folder under the same test platform workstation and runs import maintenance procedure and has all the data as expected. (Also noted is I dond have any SERP services running on the test platform workstation)

The challenge here is configuring the workout in the server folder as explained in the 1st paragraph above.

See the attached files layout screenshots both the client folder and the server folder to support the above. I have also attached both logs files for both the client and the server folder

Kind regards,

Macharia
Please log in to view the files
Kenneth Macharia
2020-01-31
Created byKenneth Macharia12:41 30 Jan 2020
HI Michael, Thanks. The main challenge is, none of any .exe files can run in the server folder located in my test platform. If you attempt Standard ERP Server.exe, runs a command windows and immediately closes out (creating a very small size of .hdb in
HI Michael,

Thanks. The main challenge is, none of any .exe files can run in the server folder located in my test platform. If you attempt Standard ERP Server.exe, runs a command windows and immediately closes out (creating a very small size of .hdb in the folder) and /or if you run Standard ERP.exe in the same server folder on test platform then it gives you side-to-side configuration error.

NB: However, Standard ERP.exe runs very well in the client folder under the same test platform workstation and runs import maintenance procedure and has all the data as expected. (Also noted is I dond have any SERP services running on the test platform workstation)

The challenge here is configuring the workout in the server folder as explained in the 1st paragraph above.

See the attached files layout screenshots both the client folder and the server folder to support the above. I have also attached both logs files for both the client and the server folder

Kind regards,

Macharia
Please log in to view the files
Michael Wyeth
2020-02-04
Hi Kenneth

For the SERP server, please remove its small hdb. Then, import the backup using the command line. this can be done by changing directory to the the SERP server folder, then running "[server exe] [backup]". Once the backup is imprted, close the command line, and open the service manager. From there, find the service "Standard ERP server" and start it.

Once the server is running, try to connect a client to it.

Best regards,

Hansaworld Support
This thread has been closed for further comments. Please create a new thread
Back to the list
Latest Posts
Miguel Silva
Bom dia Não recebi nenhum arquivo!...
23:07 28 Sep 2020
Simone M.
Hi Jake, I'll test it to check if it's repeatable on my side as well. If yes, I'll fill a bug repo...
17:02 25 Sep 2020
You can subscribe to notifications for any post in this forum by selecting the 'star' icon on the top right corner of the topics list. You have to log in to use this functionality.