Printing empty data fields
Sam Rowell
2017-05-31
I am creating a new report using Report Generator to simplify exporting customer data in a format that meets our company's needs.

Not every report field has been completed in Hansa for every customer in the report results and when the data is exported to Excel these blank fields are ignored which misaligns the data results under the wrong headers.

For example

Report headers: Number, Name, Address1, Address 2, City, Post code, Telephone
Report results:
Customer1 = Number, Name, Address1, Address 2, City, County, Telephone (No post code)

Customer2 = Number, Name, Address1, Address 2, City, Post code, Telephone (No County)


Using the above example, my excel results return a post code under a county header for customer 2, a telephone number under a post code header and no telephone number for both customers.


If the report generator cannot export empty fields then it is pretty useless...

Is there a function that can be applied to correct this so that I can export data to Excel efficiently and accurately?
This answer was correct
Created byEdwin11:31 1 Jun 2017
Hello Sam,

Which version of Standard ERP are you using? It sounds like this could possibly be a bug so if you please provide me with the version I will investigate it properly.


Best regards,

Edwin
HansaWorld Support
This answer was correct
Edwin
2017-06-01
Hello Sam,

Which version of Standard ERP are you using? It sounds like this could possibly be a bug so if you please provide me with the version I will investigate it properly.


Best regards,

Edwin
HansaWorld Support
Sam Rowell
2017-06-01
Created byEdwin11:31 1 Jun 2017
Hello Sam, Which version of Standard ERP are you using? It sounds like this could possibly be a bug so if you please provide me with the version I will investigate it properly. Best regards, Edwin HansaWorld Support
Current version is Standard ERP 8.2 2016-12-18

Intel/Windows XP/Windows 7
Build 82211904
Edwin
2017-06-07
Created bySam Rowell11:36 1 Jun 2017
Current version is Standard ERP 8.2 2016-12-18 Intel/Windows XP/Windows 7 Build 82211904
I would suggest updating to our latest version (8.3) to see if that solves the issue. If not, I recommend consulting with one of our service partners to make sure that the report is set up correctly.

Best regards,

Edwin
Sam Rowell
2017-06-14
Feedback from our service partner:

"this has always been the case with Hansa"

Can you definitively state that upgrading WILL fix the issue?
Back to the list
Latest Posts
Boa tarde Hansa actualizado e está o problema do ATCUD está resolvido. Cumprimentos...
19:44 2 Feb 2023
Frederico Ventura
Feito!! Obrigado pelo apoio. Cumprimentos...
16:53 25 Jan 2023
You can subscribe to notifications for any post in this forum by selecting the 'star' icon on the top right corner of the topics list. You have to log in to use this functionality.